Sunday, December 2, 2012

Adt-Bundle Bug

I am not sure if this is a bug or not. But, when you  download the adt-bundle from Google which includes Eclipse you will notice that its Eclipse 4.2.0 and not eclipse 4.2.1.  Which might be okay.

But when you attempt to upgrade it to eclipse 4.2.1 and than attempt to install either the Chrome Theme or the JBoss Central UI Theme plugins to get some nice ways to change the theme of the UI both plugins fail on the windows preferences general appearance  selection.

Why JBossTools?  Because that is the only group of plugins that has an updated framemarker plugin to allow us to make and modify new project templates as they are framemarker files. Its not a show stopper bug its just plain annoying.

The solution is probably dumping the com.android plugins from an adt-bundle install into a fresh Eclipse 4.2.1 install and tweak the eclipse.ini file to point to the right product splash screen.